Mengatasi usr/local/lib/python2.7/dist-packages/requests/__init__.py:83 di GNU/Linux


Assalamualaikum Wr.Wb...
dengan diberikan nikmat dan rezeki dari Allah SWT, saya Mr.GagalTotal666 akan
berbagi kepada anda yaitu tentang Mengatasi
usr/local/lib/python2.7/dist-packages/requests/__init__.py:83 di GNU/Linux.

berawal iseng pada saat saya sudah mengkompile tools dari bahasa pemrograman
python 2.7 setelah itu ada suatu package yang belum ada jadi jika menjalan suatu
program python di bash shell linux pesan error/warning package itu ada seterus nya
contoh seperti ini
$ /usr/local/lib/python2.7/dist-packages/requests/__init__.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.  warnings.warn(warning, RequestsDependencyWarning) curator_cli, version 5.5.4

cara mengatasi nya gampang dan tidak terlalu sulit
jadi disini kita hanya saja mengupgrade sebuah package dependensi nya
oke ikuti langkah berikut....

buka terminal/console anda
pertama mengupgrade/meningkatkan Package cyptography untuk python 2
$ sudo pip2 install --upgrade cryptography
python 3
$ sudo pip3 install --upgrade cryptography


ke dua atasi ini dengan menginstal ulang PyOpenSSL
$ sudo python -m easy_install --upgrade pyOpenSSL

done...

oke mungkin itu saja yang bisa saya bagikan kepada anda
kalau ada kekurangan dan kesalahan nya mohon berikan masukan nya ya

sekian dan semoga bermanfaat....

Wasalamualaikum Wr.Wb...

Sumber : [stackoverflow.com]
Previous
Next Post »